Apple CarPlay Issues - multiple models?

Gecko

Administrator
Messages
4,043
Reactions
9,321
Hi All,

Thanks to Lexus' generosity, I've had a few different press cars over the last few months and I've been driving a 2021 RX 350 for the last two weeks while my GX is having a creaking rear sear bracket repaired. Those cars are:

2021 RC 350
2021 LS 500
2022 IS 500
2021 RX 350

... and I've found CarPlay similarly frustrating to use in every single one of them. My 2021 GX does not have CarPlay of course, but our 2021 Camry does, so I've been excited about having it in these vehicles. Phone is an iPhone 12 Pro. I do love having Waze on the screen, but other than that, I've had a number of problems across every one of these vehicles and am finding CarPlay quite a PITA to use. Those issues are:

- Podcasts app loads very slowly and sometimes not at all
- Playlists don't fully load - most often only 5-7 of them, and I have 20+
- If playlists do load, sometimes they are grayed out and cannot be selected or played
- Screens freezing and not responding, or delaying inputs significantly
- Waze is very, very slow to load but works once it's up
- On the RX, if I enter the car on a call that transfers to CarPlay, even after I hang up, the car won't play any audio because it says "Call in progress"

We've never had any of these problems with the Camry, and I just expected that the functionality and back ends between the systems would be fairly similar, but perhaps I am wrong? One little issue here or there is nothing to worry about IMO, but every one of these cars has exhibited each of these issues with the RX being the only one to have the "call in progress" issue after I hang up. I usually end up exiting out of CarPlay and just using the native system for audio.

Has anyone else had these issues? Curious what others are experiencing.
 

Ian Schmidt

Moderator
Messages
2,140
Reactions
3,775
Some of that is likely the fault of the specific apps. I use Overcast to play podcasts (the feature where it transparently removes pauses in conversation is really nice for some podcasts) and have had no problems with it, even through the wireless CarPlay dongle from Amazon. I did get an issue once where the car refused to play audio after a call, but I'm not sure if that's the phone's fault or the car's. Disconnecting and reconnecting CarPlay fixed it.
 

Jezza819

Follower
Messages
111
Reactions
144
Android Auto is also acting up in my 21 NX300h. It takes more than one try to get the phone connected to the car and once it's connected it will randomly disconnect on it's own then reconnect several minutes later. Or I can disconnect the USB and reconnect a few times in hopes of it connecting.

The 20 NX300 I had last year didn't do this. But it could be an app issue in both systems like @Ian Schmidt said. It's very annoying whatever is causing it.
 
Last edited:
Messages
3
Reactions
0
Hi All,

Thanks to Lexus' generosity, I've had a few different press cars over the last few months and I've been driving a 2021 RX 350 for the last two weeks while my GX is having a creaking rear sear bracket repaired. Those cars are:

2021 RC 350
2021 LS 500
2022 IS 500
2021 RX 350

... and I've found CarPlay similarly frustrating to use in every single one of them. My 2021 GX does not have CarPlay of course, but our 2021 Camry does, so I've been excited about having it in these vehicles. Phone is an iPhone 12 Pro. I do love having Waze on the screen, but other than that, I've had a number of problems across every one of these vehicles and am finding CarPlay quite a PITA to use. Those issues are:

- Podcasts app loads very slowly and sometimes not at all
- Playlists don't fully load - most often only 5-7 of them, and I have 20+
- If playlists do load, sometimes they are grayed out and cannot be selected or played
- Screens freezing and not responding, or delaying inputs significantly
- Waze is very, very slow to load but works once it's up
- On the RX, if I enter the car on a call that transfers to CarPlay, even after I hang up, the car won't play any audio because it says "Call in progress"

We've never had any of these problems with the Camry, and I just expected that the functionality and back ends between the systems would be fairly similar, but perhaps I am wrong? One little issue here or there is nothing to worry about IMO, but every one of these cars has exhibited each of these issues with the RX being the only one to have the "call in progress" issue after I hang up. I usually end up exiting out of CarPlay and just using the native system for audio.

Has anyone else had these issues? Curious what others are experiencing.
None of these problems but something more basic! While CarPlay starts when the iPhone is plugged in 90-95% of the time, far too often for me, it does not connect 5-10% of the time. Have to turn off car, unplug and restart, which usually allows a connection. Sometimes 3 restarts!

I spoke to a wireless CarPlay dongle vendor who claims the USB port is flaky on the RX450h and can be replaced. Was hoping the wireless CarPlay would do an end run around the problem but it does not work with our 450h (tho they list the car as one that should work). He said most 450h purchasers have no problem...some, like us, do.

Talked to Lexus 'tech/genius' who handles CarPlay questions at our dealership. He suggested we bring it in and have the USB port tested and maybe replaced. While he didn't say so, sounds like they know there's an issue. Once connected, it works flawlessly.
 

Jezza819

Follower
Messages
111
Reactions
144
I just got back from a 1200 mile trip and I have to say Android Auto behaved much better than the last time I used it in 2021. I don't know if the app itself has been updated or what's happened but I didn't have near the trouble with it as before. The only slight hiccup I had with it was on the 10 hour initial trip after about 45 minutes or so it started that random disconnecting again that drove me nuts before. Took about 10 minutes or so of plugging in, unplugging, plugging in, etc to finally get it to stop. But on the 10 hour return trip, I connected it that morning and it never gave one issue the entire way back.
 
Messages
22
Reactions
62
CarPlay (wireless) works flawlessly for me on my LX 600. Same with my 2019 NX (wired). But I have only used Amazon Music, the phone and texting app and Google Maps. Phone is an iPhone 12 Pro.